Tags:
create new tag
, view all tags

Question

Hi,

Please see http://twiki.org/cgi-bin/view/Sandbox/AttachmentTest?sortcol=4;table=1;up=1#sorted_table for a reference. The dates are sorted alphabetically - see attach2.txt that is attached to that topic. It doesn't work on our own TWiki deployment either but the fact that it fails on twiki.org points to a general bug rather than a config / deployment issue

I couldn't see any issues logged on the support web for this.

Anyone any ideas?

Many thanks,

Dave

Environment

TWiki version: TWikiRelease04x02x02
TWiki plugins: DefaultPlugin, EmptyPlugin, InterwikiPlugin, TablePlugin
Server OS: twiki.org server os
Web server: twiki.org web server
Perl version: twiki.org perl version
Client OS: WinXP Pro SP2
Web Browser: Firefox 3 or IE 7
Categories: Plugins, Add-Ons

-- ChrisBooth - 16 Sep 2008

Answer

ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.

That looks like a bug indeed. Let's see how a normal table behaves:

Title DateSorted ascending
MNO 06 Feb 2006 - 19:02
DEF 07 Feb 2006 - 13:23
ABC 26 May 2007 - 22:36
GHI 26 Jul 2007 - 13:23
JKL 16 Sep 2008 - 09:48

No problem here. It must be in the attachment table then.

The strange thing is that with the attachment table the url says "sortcol=4" while the sorted column is number 5.

-- ArthurClemens - 16 Sep 2008

I thought the sortcol is 0 based, i.e. Icon = 0 Attachment = 1 Action = 2 Size = 3 Date = 4

Is that right?

-- ChrisBooth - 16 Sep 2008

You are right. Confusing and not clear from the documentation. So the issue here is something else.

No, the first column has number 1. So Icon = 1.

-- ArthurClemens - 16 Sep 2008

Added one more row to this test case to show that, effectively, July comes after May.

-- RafaelAlvarez - 16 Sep 2008

Any workarounds?

-- ChrisBooth - 22 Sep 2008

I just ran into the same problem. Until I have a client willing to pay for me to look at it I'm just going to file it as a bug. M.

-- MartinCleaver - 30 Sep 2008

I've filed it as TWikibug:Item6031 but, err., Is the table above right now??

-- MartinCleaver - 30 Sep 2008

The table above is right, but the attachment table of the original bug is not.

-- ArthurClemens - 30 Sep 2008

Closing this after more than 30 days of inactivity. Please feel free to re-open if needed.

-- PeterThoeny - 07 Nov 2008

Change status to:
Edit | Attach | Watch | Print version | History: r11 < r10 < r9 < r8 < r7 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r11 - 2008-11-07 - PeterThoeny
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.