create new tag
, view all tags


Installed Twiki using the instructions here TWikiVMDebianStable

Also installed the action tracker plugin. ActionTrackerPlugin

I can add actions and view them but I cannot seem to go to the action (ie change the state of the action ) by clicking on the "go to action" link on the web page. Also when I click on Edit it brings up the edit page for the whole page and does not bring up a pop up of the actual action.


TWiki version: TWikiRelease04x00x04
TWiki plugins: ActionTracker
Server OS: Debian Linux
Web server:  
Perl version: 5.8.4
Client OS: Win XP
Web Browser: IE
Categories: Plugins

-- JyotirmoySharma - 21 Jun 2007


ALERT! If you answer a question - or someone answered one of your questions - please remember to edit the page and set the status to answered. The status selector is below the edit box.

I share the same problem as JyotirmoySharma, with the same software versions and also on Debian (under VM on WinXP). Only difference is that I use Firefox instead.

I've tried to ensure that all files and folders relevant to ActionTracker have correct permissions set, but, being a newbie, I might have missed some.

Any suggestions?

-- HenrikLundin - 05 Jul 2007

What skin? What plugins are installed? What authentication method is in use? Are the permissions on the files in templates set so that the webserver user can read them all?

-- CrawfordCurrie - 12 Jul 2007

Plugins: SpreadSheetPlugin, ActionTrackerPlugin, CommentPlugin, EditTablePlugin, InterwikiPlugin, PreferencesPlugin, RedirectPlugin, SlideShowPlugin, SmiliesPlugin, TablePlugin, WysiwygPlugin

Authentication method: TWiki::Client::TemplateLogin (not sure this is what you're asking for...)

Skin: PatternSkin (default)

I've checked the permissions on the files in templates. Indeed, these were set wrong, but changing to ownership www-data:www-data and permission 744 did not solve my problem. Any other ideas?


-- HenrikLundin - 08 Aug 2007

Ahhh at last I've found a page that talks about the problem I'm having. I assume that the popup edit function is handled by the atp.js file. I have checked the html source from within my IE7 browser and the code looks okay. Within the file I see the following lines referring to ActionTracker

<base href="http://twiki/twiki/bin/view/TWiki/ActionTrackerPlugin"></base><!--/closing tag 'solves' IE selection bug-->


<!--ACTIONTRACKERPLUGIN_CSS--><link rel="stylesheet" href="http://twiki/twiki/pub/TWiki/ActionTrackerPlugin/styles.css" type="text/css" media="all" />
and then an action edit link looks like:

<!--ACTIONTRACKERPLUGIN_JS--><script type='text/javascript' src='/twiki/pub/TWiki/ActionTrackerPlugin/atp.js'></script>

<a href="http://twiki/twiki/bin/edit/TWiki/ActionTrackerPlugin" onclick="return atp_editWindow('http://twiki/twiki/bin/edit/TWiki/ActionTrackerPlugin')">edit</a>
This all looks good. I can open the js and css from within the browser so I don't think it's permissions problem. I too am using the VM. One early issue I found is that my installation didn't seem to be resolving the %SYSTEMWEB% variable. I modified the pm files to use %TWIKIWEB% (despite the System name being set to TWiki in the configure screen. Seems like this might be an issue with VM?

  • My environment is:

-- AndrewRobinson - 14 Sep 2007

Upon more investigation this seems to be a javascript problem. The JSCalendarContrib is also not working. Oddly I'm not getting any javascript warnings in IE. I have tried this with both IE7 and IE6 with the same results. I think the javascript is functioning enough to open the popup window as clicking on the EDIT link for an action pops up a new window but the content is just a normal page edit.

-- AndrewRobinson - 14 Sep 2007

I have downloaded the latest TWikiVM and foud that the %SYSTEMWEB% variable doesn't seem to work. I assume having it in a page content should resolve to TWiki on a normally functioning system, as does %MAINWEB%.

-- AndrewRobinson - 18 Sep 2007

I found that the file /templates/edit.action.tmpl has a two lines that import some css files. These lines are hard coded with http://daphne/ so I changed the daphne to my actual host name... doesn't seem to have fixed anything. changed

@import url('http://daphne/MAIN/pub/TWiki/TWikiTemplates/base.css');
@import url('http://daphne/MAIN/pub/TWiki/TWikiTemplates/default.css');
@import url('http://twiki-vm/MAIN/pub/TWiki/TWikiTemplates/base.css');
@import url('http://twiki-vm/MAIN/pub/TWiki/TWikiTemplates/default.css');

I edited the file atp.js and added some alerts to troubleshoot the javascript and it verified that the java script is running in the browser okay. I got the alert to popup when you change the status of an action that's displayed on a page using the actionsearch. When I change the status from Open to Close, I get a popup displaying the url


I then tried this url directly in the brower address bar and get the following response

Invalid Command Main

take out the Main bit - use url

and I get

Unknown Action ActionTrackerPlugin/TopicName

hmmm I'm off to read up more about how plugins work.

-- AndrewRobinson - 19 Sep 2007

You might want to try to debug this with Firefox then re-test with IE once solved - it has more useful error reporting for JavaScript in some cases, and tools such as Firebug also help debugging a lot.

-- RichardDonkin - 19 Sep 2007

thanks Richard. I did try the functionality in firefox and got the same result, though I wouldn't have been surprised if it was an IE problem. I think it's something more fundamental between the Plugins and the TWikiVM. The fact that SYSTEMWEB is used by the plugins but doesn't appear to resolve on the TWikiVM indicates there's something amiss (to me anyway). I didn't want to raise a bug until I can isolate where the problem is.

-- AndrewRobinson - 20 Sep 2007

just a msg to say I'm away for a few weeks so won't have an update on this for a while longer.

-- AndrewRobinson - 02 Oct 2007

I also discovered the behaviour that the action-edit functionality does not work correctly with TWiki 4.0 (opens whole page in Edit mode), it disappeared by installing TWiki-4.1.2

-- ChrisHausen - 15 Oct 2007

Thanks Chris, I suspected as much. Just need to wait for the VM Image to be updated to 412.

-- AndrewRobinson - 14 Nov 2007

You don't have to wait; just

Note we have reverted this change again in plugins due to this sort of problem.

-- CrawfordCurrie - 24 Nov 2007

Andrew, were do I insert this line?


-- HenrikLundin - 26 Nov 2007

Do the

in your TWiki.TWikiPreferences.

-- PeterThoeny - 01 Jan 2008

Hello, i have a twiki installation with exact the same problems . Setting SYSTEMWEB does not resolve the problem. I have changed the javascript atp.js to get the url in an alert window, by using this url i get the error message "invalid command main" on the browser window. Did anybody reslov this problem? TWiki Debian Paket Version 1:4.0.5-9.1

Thanks ..

-- DietmarFackelmann - 21 Feb 2009

Closing this question after more than 30 days of inactivity. Feel free to reopen if needed. Consider engaging one of the TWiki consultants if you need timely help. We invite you to get involved with the community, it is more likely you get community support if you support the open source project!

Also, better to open a new question (with details.)

-- PeterThoeny - 2009-04-17

Change status to:
Edit | Attach | Watch | Print version | History: r19 < r18 < r17 < r16 < r15 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r19 - 2009-04-17 - PeterThoeny
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.