Tags:
create new tag
, view all tags

Bug: %INCLUDE attachment fails on twiki.org

Attach a text file to a topic. INCLUDE that text file into a topic and you get:

ERROR: TWiki::Net::getUrl connect: Connection timed out. GET /p/pub/Plugins/SeeSkin/SeeSkin.txt HTTP/1.1 Host: twiki.org

I have no problem using this technique on Cygwin with Apache v2 or v1.3, 2002-Aug and 2002-Dec betas.

On twiki.org I have also been unable to get includes working using any of ATTACHURL, ATTACHURLPATH, PUBURL, PUBURLPATH.

Test case

See Sandbox.InlcudeAttachTest (yes, I know it is spelled wrong, but I can't fix it.)

Environment

TWiki version: current alpha (twiki.org)
TWiki plugins:  
Server OS:  
Web server:  
Perl version:  
Client OS:  
Web Browser:  

-- MattWilkie - 12 Dec 2002

Follow up

This is a current limitation of hosting TWiki.org at SourceForge. They do not offer (or tell?) the proxy settings to get web pages from within the web servers. Same issue if accessing a web page from TWiki.org web site.

I asked for more information on that some time ago, see https://sourceforge.net/tracker/?func=detail&aid=599745&group_id=1&atid=350001

-- PeterThoeny - 12 Dec 2002

Fix record

Edit | Attach | Watch | Print version | History: r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r2 - 2002-12-12 - PeterThoeny
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.