Tags:
create new tag
, view all tags

Bug: Using %INCLUDE macro messes up home page format

Originally posted under Support web; I think this is a bug.

I thought it would be fun to include the contents of my offsite home page in my TWiki home page (i.e. within my Main.VickiBrown page). So, at the bottom of my TWiki home page, I placed

%INCLUDE{"http://www.cfcl.com/vlb/Jobweb/index.html"}%

The results were... unexpected.

The insertion of that line caused all formatting of all previous lines to go haywire. This looks like a bug to me... while I might expect the formatting to go off kilter within HTML <HEAD> and <BODY> tags (which are part of the %INCLUDE'd page) the original page text is outside of those tags and should not, therefore, be affected.

(btw, the test and the screenshot are taken from my Company installation of TWiki; I get an error if I try to insert the same %INCLUDE% line here on twiki.org.

Test case

http://www.twiki.org/p/pub/Codev/INCLUDEdisorganizesPageFormat/TWiki_results.pdf

Environment

TWiki version: TWikiRelease02Sep2004
TWiki plugins: DefaultPlugin, EmptyPlugin, InterwikiPlugin
Server OS: FreeBSD
Web server: Apache
Perl version: 5.005
Client OS:  
Web Browser:  

-- VickiBrown - 03 Jan 2005

Follow up

Fix record

Topic attachments
I Attachment History Action Size Date Who Comment
PDFpdf TWiki_results.pdf r1 manage 94.7 K 2005-01-03 - 17:30 VickiBrown  
Topic revision: r1 - 2005-01-03 - VickiBrown
 
  • Learn about TWiki  
  • Download TWiki
This site is powered by the TWiki collaboration platform Powered by Perl Hosted by OICcam.com Ideas, requests, problems regarding TWiki? Send feedback. Ask community in the support forum.
Copyright © 1999-2017 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.